Форум программистов
 
Контакты: о проблемах с регистрацией, почтой и по другим вопросам пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail.

Вернуться   Форум программистов > Клуб программистов > Свободное общение
Регистрация

Восстановить пароль
Повторная активизация e-mail

Здесь нужно купить рекламу за 25 тыс руб в месяц! ) пишите сюда - alarforum@yandex.ru

Результаты опроса: Какую Delphi выбрать?
Delphi 2005 0 0%
Delphi 2006 0 0%
Delphi 2007 8 29.63%
Delphi 2009 1 3.70%
Delphi 2010 18 66.67%
Голосовавшие: 27. Вы ещё не голосовали в этом опросе

Ответ
 
Опции темы
Старый 17.03.2010, 19:59   #1
W0LF
Форумчанин
 
Аватар для W0LF
 
Регистрация: 28.03.2008
Сообщений: 940
Вопрос Какую версию Delphi выбрать?

Люди, вот возник такой вопрос, несколько лет кодил только на Delphi 7, но сейчас что-то стукнуло в голову и я её удалил, решил перейти на более свежую версию... Ток не могу выбрать какую? Какую из нынешних версий вы предложите? Слышал много "хорошего" про 2009... Так же что некоторые версии даже справок не имеют... Короче, предлагайте...
W0LF вне форума   Ответить с цитированием
Старый 17.03.2010, 20:19   #2
Яр|/||< (^_^)
LosYear
Форумчанин
 
Аватар для Яр|/||< (^_^)
 
Регистрация: 19.06.2009
Сообщений: 695
По умолчанию

Я работаю на 2010. Немного есть несовместимость со старыми програми. НО из всех моих многочисленых проектов не работает токо один.
Я голосую за 2010!
Яр|/||< (^_^) вне форума   Ответить с цитированием
Старый 17.03.2010, 20:26   #3
russian-stalker
Участник клубаДжуниор
 
Аватар для russian-stalker
 
Регистрация: 23.08.2008
Сообщений: 1,616
По умолчанию

Юзаю 2009. Единственно, что не нравится, так это юникодица(можете считать меня сумашедшим). Хотя иногда и 7 юзаю.
russian-stalker вне форума   Ответить с цитированием
Старый 17.03.2010, 20:37   #4
W0LF
Форумчанин
 
Аватар для W0LF
 
Регистрация: 28.03.2008
Сообщений: 940
По умолчанию

Во-во, не имею огромного желания переходить на 2009/10 из за юникода... Но и семерка уже старая и меня честно говоря достала... Может 2007 ?
W0LF вне форума   Ответить с цитированием
Старый 17.03.2010, 21:03   #5
raxp
Старожил
 
Регистрация: 29.09.2009
Сообщений: 9,742
По умолчанию

...вообще подобное обсуждение уже было ...пользую в основном delphi6, сейчас переношу свои компоненты на бесплатный turbo delphi lite, если все будет ок, пересяду на него, так как он портабле.
Разработки и научно-технические публикации :: Видеоблог :: Твиттер
Radar systems engineer & Software developer of industrial automation
raxp вне форума   Ответить с цитированием
Старый 17.03.2010, 21:08   #6
Mixasik
New Delphi Coder
Форумчанин Подтвердите свой е-майл
 
Аватар для Mixasik
 
Регистрация: 20.07.2008
Сообщений: 874
По умолчанию

Я использую Delphi 2010 и полностью доволен. Чем Вам не нравится unicode? По-моему очень удобен. Так что мой выбор Delphi 2010
Страх это слабость и потому, кто испугался уже побежден.
Mixasik вне форума   Ответить с цитированием
Старый 17.03.2010, 21:26   #7
russian-stalker
Участник клубаДжуниор
 
Аватар для russian-stalker
 
Регистрация: 23.08.2008
Сообщений: 1,616
По умолчанию

Например, нужно писать новые врапперы для старых Dll, не поддерживающих юникод.
russian-stalker вне форума   Ответить с цитированием
Старый 17.03.2010, 22:06   #8
Яр|/||< (^_^)
LosYear
Форумчанин
 
Аватар для Яр|/||< (^_^)
 
Регистрация: 19.06.2009
Сообщений: 695
По умолчанию

Цитата:
Я использую Delphi 2010 и полностью доволен. Чем Вам не нравится unicode? По-моему очень удобен. Так что мой выбор Delphi 2010
Полностью согласен
Яр|/||< (^_^) вне форума   Ответить с цитированием
Старый 17.03.2010, 23:06   #9
mutabor
Телепат с дипломом
Старожил
 
Аватар для mutabor
 
Регистрация: 10.06.2007
Сообщений: 4,929
По умолчанию

Использую 2009. Решать Вам в любом случае, пользоваться старьем или новой версией. Так как у всех разные задачи, то каждый по своему советовать будет. Принимайте решение исходя из ваших задач.

Так как ваша задача сводится к "что-то стукнуло в голову и я её удалил, решил перейти на более свежую версию..." то что-либо посоветовать трудно
mutabor вне форума   Ответить с цитированием
Старый 18.03.2010, 02:23   #10
JTG
я получил эту роль
Старожил
 
Аватар для JTG
 
Регистрация: 25.05.2007
Сообщений: 3,694
По умолчанию

Если не нужен юникод - устанавливай 2007, в 2009/10 могут быть проблемы со старыми компонентами
пыщь
JTG вне форума   Ответить с цитированием
Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Какую выбрать CMS? alexgta567 WordPress и другие CMS 2 12.02.2010 12:23
Какую купить версию книги Стивена Прата. Запутался. spamer Свободное общение 0 26.01.2010 04:01
какую видюху выбрать? gores Железо 0 26.11.2009 18:40
какую версию delphi использовать. motya770 Софт 2 10.07.2009 19:21
Какую архитектуру выбрать? k376 Помощь студентам 2 23.04.2008 23:57


03:21.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.