Форум программистов
 
Контакты: о проблемах с регистрацией, почтой и по другим вопросам пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail.

Вернуться   Форум программистов > Microsoft Office и VBA > Microsoft Office Excel
Регистрация

Восстановить пароль
Повторная активизация e-mail


Ответ
 
Опции темы
Старый 28.11.2019, 14:45   #1
Onehunter
Пользователь
 
Регистрация: 16.10.2010
Сообщений: 30
По умолчанию как то сцепить через символ для последующего экспорта на сайт. листинг директорий по файлам

Прошу подсказать, сам не могу справиться (красным выделил столбец)
Есть листинг директорий файлов (фото). они относятся, в каждой отдельной папке, к одному продукту. нужно их как то сцепить через символ для последующего экспорта на сайт.
Вложения
Тип файла: xlsx _image_in — копия.xlsx (10.4 Кб, 9 просмотров)
Onehunter вне форума Ответить с цитированием
Старый 28.11.2019, 22:20   #2
сфинкс
Форумчанин
 
Аватар для сфинкс
 
Регистрация: 17.06.2012
Сообщений: 358
По умолчанию

что требуется в результате не указано

на 1-й взгляд надо сцеплять
Код:
=СЦЕПИТЬ(A1;"\";B1;"\";C1)
учим C# зная basic & excel
сфинкс на форуме Ответить с цитированием
Старый 28.11.2019, 23:51   #3
Onehunter
Пользователь
 
Регистрация: 16.10.2010
Сообщений: 30
По умолчанию

Цитата:
Сообщение от сфинкс Посмотреть сообщение
что требуется в результате не указано

на 1-й взгляд надо сцеплять
Код:
=СЦЕПИТЬ(A1;"\";B1;"\";C1)
нет, нужно сцепить все названия имен файлов, сопричастных одной товарной позиции (ближняя корневая папка). независимо от того, сколько их там (1, 2, 3 и тд). если бы их там было одинаковое кол-во - проблемы нет. а вот выполнять проверку на диапазоны - мне и непонятно как
Onehunter вне форума Ответить с цитированием
Старый 29.11.2019, 00:39   #4
сфинкс
Форумчанин
 
Аватар для сфинкс
 
Регистрация: 17.06.2012
Сообщений: 358
По умолчанию

мало что понятно без примера
зато новый вариант: учитывать вышележащий результат

=ЕСЛИ(B5=B6;СЦЕПИТЬ(E4;C5;D5;C6);"" )

имя_0352.jpg&имя_4864.jpgимя_4864.j pg&имя_4865.jpgимя_4865.jpg&имя_016 0.jpg

тогда в новом столбце легко обособить нужные
если строка пустая тогда берём ячейку сверху
учим C# зная basic & excel
сфинкс на форуме Ответить с цитированием
Старый 29.11.2019, 01:43   #5
Onehunter
Пользователь
 
Регистрация: 16.10.2010
Сообщений: 30
По умолчанию

Цитата:
Сообщение от сфинкс Посмотреть сообщение
мало что понятно без примера
зато новый вариант: учитывать вышележащий результат

=ЕСЛИ(B5=B6;СЦЕПИТЬ(E4;C5;D5;C6);"" )

имя_0352.jpg&имя_4864.jpgимя_4864.j pg&имя_4865.jpgимя_4865.jpg&имя_016 0.jpg

тогда в новом столбце легко обособить нужные
если строка пустая тогда берём ячейку сверху
спасибо вам за помощь. но я не очень понял как эту формулу применить. результат нужен такой (рассчитываемый, естественно, на автомате, тк файлов тысячи, и их содержимое в каждой папке, которая и есть равно товарная позиция, произвольное) -
Вложения
Тип файла: xlsx _image_in — копия.xlsx (10.6 Кб, 3 просмотров)

Последний раз редактировалось Onehunter; 29.11.2019 в 01:56.
Onehunter вне форума Ответить с цитированием
Старый 29.11.2019, 08:45   #6
сфинкс
Форумчанин
 
Аватар для сфинкс
 
Регистрация: 17.06.2012
Сообщений: 358
По умолчанию

результаты в нижней части
и включен дополнительный столбец

=ЕСЛИ(B14=B15;СЦЕПИТЬ(E14;"&";C15); C15 )
=ЕСЛИ(B15=B16;"";E15)

Код:
имя_4392.jpg&имя_4811.jpg



имя_0352.jpg&имя_4864.jpg&имя_4865.jpg&имя_0160.jpg
имя_5945.jpg


имя_1625.jpg&имя_1634.jpg&имя_2600.jpg
моя идея учитывать предыдущий результат правильная
но как объединить столбцы в одну формулу не знаю
и сам подобные решаю в несколько столбцов
Вложения
Тип файла: xlsx _image_in_sfinx.xlsx (11.2 Кб, 5 просмотров)
учим C# зная basic & excel

Последний раз редактировалось сфинкс; 29.11.2019 в 09:47.
сфинкс на форуме Ответить с цитированием
Старый 29.11.2019, 21:16   #7
Onehunter
Пользователь
 
Регистрация: 16.10.2010
Сообщений: 30
По умолчанию

Цитата:
Сообщение от сфинкс Посмотреть сообщение
и сам подобные решаю в несколько столбцов
выручили! спасибо вам огромное. задать новый столбец не проблема
Onehunter вне форума Ответить с цитированием
Ответ

Здесь нужно купить рекламу за 20 тыс руб в месяц! ) пишите сюда - alarforum@yandex.ru
Без учёта ботов - 20000 человек в день, 350000 в месяц.

Опции темы


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Символ переноса строк для функции =СЦЕПИТЬ Jeni Microsoft Office Excel 6 19.06.2017 09:47
Обращение к файлам через ComboBox vova09 Общие вопросы Delphi 2 29.04.2016 12:31
Удалить дупликаты + ВПР и СЦЕПИТЬ через символ Евгений Таб Microsoft Office Excel 6 25.09.2014 12:18
Как сцепить данные с определенного диапазона ячеек через запятую Alex___ Microsoft Office Excel 5 21.01.2013 23:42
Cамый краткий листинг - самый подробный листинг. katia2011 Assembler - Ассемблер 2 13.04.2011 19:10