Форум программистов
 
Контакты: о проблемах с регистрацией, почтой и по другим вопросам пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail.

Вернуться   Форум программистов > Microsoft Office и VBA > Microsoft Office Excel
Регистрация

Восстановить пароль
Повторная активизация e-mail


Донат для форума - использовать для поднятия настроения себе и модераторам

А ещё здесь можно купить рекламу за 25 тыс руб в месяц! ) пишите сюда - alarforum@yandex.ru

Закрытая тема
Ваша тема закрыта, почему это могло произойти? Возможно,
Название темы включает слова - "Помогите", "Спасите", "Срочно"
Название темы не отражает сути вашего вопроса.
Тема исчерпала себя, помните, один вопрос - одна тема
Прочитайте >>>правила <<< и заново правильно создайте тему.
 
Опции темы
Старый 06.12.2006, 12:00   #1
khvorovs
Новичок
 
Регистрация: 06.12.2006
Сообщений: 2
Репутация: 10
По умолчанию помогите сделать сравнение трех книг.

в трех книгах имеются номенклатурные номера находящиеся в столбце B, номера расположенны хаотично. нужно в первую книгу достать данные из остальных двух книг, всё осложняется тем что номенклатурные номера не по порядку, нужно придумать как из первой книги брать автоматом номера в порядке как они идут в этой книге, найти эти же номера в столбце В ещё двух книг, затем из строк в столбце которых обнаружатся одинаковые номенклатурные номера книги 2 столбцы D и E данные перенести в столбцы F и G и из книги 3 также в столбцы H и I номера в каждой книге пропечатанны только один раз и больше в ней не повторяются.
помогите пожалуйста я ручками это буду делать до следующего нового года.

Последний раз редактировалось khvorovs; 06.12.2006 в 12:04.
khvorovs вне форума  
Старый 06.12.2006, 20:58   #2
infinitiv
Пользователь
 
Регистрация: 05.12.2006
Сообщений: 23
Репутация: 50
По умолчанию

Функция ВПР.

Ищет значение в крайнем левом столбце таблицы и возвращает значение в той же строке из указанного столбца таблицы.

Размещаете ее в столбцах от F до I.

ВПР(искомое_значение;таблица ;номер_столбца ;интервальный_просмотр)

Искомое_значение — это значение, которое должно быть найдено в первом столбце массива .
В Вашем случае значение располагается в столбце B

Таблица — таблица с информацией, в которой ищутся данные.
Требуется указать диапазон поиска. В Вашем случае - Книга2 B:E и Книга3 B:E

Номер_столбца — это номер столбца в массиве «таблица», в котором должно быть найдено соответствующее значение.
В Вашем случае столбец B имеет номер 1, столбец С - номер 2, столбец D - номер 3, столбец E - номер 4.

Интервальный просмотр - укажите 0.

Если совпадение не найдено, то возвращается значение ошибки #Н/Д.

Мной для проверки использованы три файла Книга1, Книга2 и Книга3. Каждый файл содержит столбец В с уникальными номерами и столбцы D и E со случайными числами.
Ячейка F1 содержит формулу: =ВПР(B1;[Книга2]Лист1!$B:$E;3;0)
Ячейка G1 содержит формулу: =ВПР(B1;[Книга2]Лист1!$B:$E;4;0)
Ячейка H1 содержит формулу: =ВПР(B1;[Книга3]Лист1!$B:$E;3;0)
Ячейка I1 содержит формулу: =ВПР(B1;[Книга3]Лист1!$B:$E;4;0)

Далее формулы распространяются на нужный интервал, при помощи "маркера заполнения".
infinitiv вне форума  
Старый 09.12.2006, 14:58   #3
khvorovs
Новичок
 
Регистрация: 06.12.2006
Сообщений: 2
Репутация: 10
По умолчанию большое спасибо щас буду пробовать

хотя честно и не ожидал что ктото ответит, ещё раз большое спасибо!
khvorovs вне форума  
Закрытая тема

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Свод из разных книг RUBEY Microsoft Office Excel 5 23.08.2008 13:25
какая из трех сортировок (обменная,исчерпыванием,выбором) самая быстрая? Cyberbest Помощь студентам 2 26.04.2008 10:34
Поиск книг по .NET Fire.id Общие вопросы .NET 5 11.04.2008 21:17
Помогите мне пожалуйста!На счёт книг! SADAM Свободное общение 1 08.06.2007 14:26
Сложение трех полей buk Microsoft Office Access 2 14.03.2007 12:29


00:54.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.