Форум программистов
 
О проблемах, например, с регистрацией пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail, а тут можно восстановить пароль.

Вернуться   Форум программистов > Microsoft Office и VBA > Microsoft Office Excel
Регистрация

Восстановить пароль
Повторная активизация e-mail

Здесь нужно купить рекламу за 20 тыс руб в месяц! ) пишите сюда - alarforum@yandex.ru
Без учёта ботов - 20000 человек в день, 350000 в месяц.

Ответ
 
Опции темы
Старый 05.02.2010, 13:37   #1
Ruben
Новичок
Джуниор
 
Регистрация: 05.02.2010
Сообщений: 2
По умолчанию Вернуть пустую ячейку

Есть 3 ячейки: A1, A2, A3.

В А1: 2
В A2: =ЕСЛИ(A1=1;"Yes";"")
В A3: =ЕСЛИ(ЕПУСТО(B1);"Yes";"No")

По идее, в ячейке А2 должно быть пусто, если в А1 не написано "1". Визуально так и есть. Но формула в А3, проверяющая пуста или нет ячейка А2, не принимает ее как пустую.

В чем проблема? И как сделать так, чтоб ячейка была «по-настоящему» пуста, а не только визуально.

Заранее спасибо.
Ruben вне форума Ответить с цитированием
Старый 05.02.2010, 13:42   #2
Serge_Bliznykov
Старожил
 
Регистрация: 09.01.2008
Сообщений: 26,260
По умолчанию

ячейка A2 не пуста, т.к. в ней находится Ваша формула!!

самый простой способ решить проблему - изменить формулу в ячейке A3
Код:
=ЕСЛИ(ИЛИ(ЕПУСТО(A2);A2="");"Yes";"No")
Serge_Bliznykov вне форума Ответить с цитированием
Старый 05.02.2010, 14:18   #3
Ruben
Новичок
Джуниор
 
Регистрация: 05.02.2010
Сообщений: 2
По умолчанию

Цитата:
Сообщение от Serge_Bliznykov Посмотреть сообщение
ячейка A2 не пуста, т.к. в ней находится Ваша формула!!

самый простой способ решить проблему - изменить формулу в ячейке A3
Код:
=ЕСЛИ(ИЛИ(ЕПУСТО(A2);A2="");"Yes";"No")
Вопрос в том, что после этой формулы, мне нужно удалять все пустые строки из файла (строк с вышеуказанными формулами будет много), которые, по сути, пустыми не являются.
Ruben вне форума Ответить с цитированием
Старый 05.02.2010, 17:20   #4
Serge_Bliznykov
Старожил
 
Регистрация: 09.01.2008
Сообщений: 26,260
По умолчанию

Цитата:
Вопрос в том, что после этой формулы, мне нужно удалять все пустые строки из файла
вопрос в том, как Вы собираетесь удалять пустые строки?
Формулой этого сделать нельзя.
Ручками? Макросом? Если макросом - то там легко изменить условие проверки, какие строчки считать пустыми...
Serge_Bliznykov вне форума Ответить с цитированием
Ответ

Здесь нужно купить рекламу за 20 тыс руб в месяц! ) пишите сюда - alarforum@yandex.ru
Без учёта ботов - 20000 человек в день, 350000 в месяц.

Опции темы


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Копирование данных на первую пустую ячейку kzld Microsoft Office Excel 8 15.07.2009 14:06
Помогите вернуть настройки!! USN Операционные системы общие вопросы 3 25.05.2009 15:20
Записать текст лесенкой(по одному слову в строке),вставляя пустую строку после каждого четверостишья klindk Паскаль, Turbo Pascal, PascalABC.NET 2 27.11.2008 15:34
если поле Patr пусто или null то пустую строку возвращает azat БД в Delphi 5 01.02.2008 14:05
как удалить пустую страницу? Gambler Microsoft Office Word 1 29.10.2006 21:57


Проекты отопления, пеллетные котлы, бойлеры, радиаторы
интернет магазин respective.ru
Пеллетный котёл Emtas
котлы EMTAS