Форум программистов
 
Контакты: о проблемах с регистрацией, почтой и по другим вопросам пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail.

Вернуться   Форум программистов > Microsoft Office и VBA > Microsoft Office Excel
Регистрация

Восстановить пароль
Повторная активизация e-mail

Здесь нужно купить рекламу за 25 тыс руб в месяц! ) пишите сюда - alarforum@yandex.ru
Без учёта ботов - 20000 человек в день, 350000 в месяц.

Ответ
 
Опции темы
Старый 12.08.2019, 18:38   #1
meidiland
 
Регистрация: 28.10.2013
Сообщений: 3
По умолчанию Суммирование массивов с шагом

Коллеги, добрый день. Необходимо просуммировать каждые 3 столбца, но с шагом через 1 столбец (A+B+C, D-пропуск, E+F+G; и т.д.).
Для суммирования каждых трех столбцов использую формулу:
=СУММ(СМЕЩ($A$1;;(СТОЛБЕЦ()-1)*3;;3))
А вот как добавить к ней условие пропуска следующего столбца - не могу додуматься. Посмотрите пжл пример.

Заранее благодарен за подсказку!
Вложения
Тип файла: xlsx Book1.xlsx (8.9 Кб, 15 просмотров)
meidiland вне форума   Ответить с цитированием
Старый 12.08.2019, 20:16   #2
IgorGO
МегаМодератор
СуперМодератор
 
Аватар для IgorGO
 
Регистрация: 05.02.2008
Сообщений: 9,251
По умолчанию

Код:
=СУММПРОИЗВ(R[1]C[-21]:R[2]C[-2]*(ОСТАТ(СТОЛБЕЦ(RC[-21]:RC[-2]);4)>0))
Вложения
Тип файла: xlsx Book1 (2).xlsx (10.1 Кб, 11 просмотров)
41001804815208 - Яндекс-деньги благодарности за удачные советы и решения можно отправлять прямо сюда)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете
IgorGO на форуме   Ответить с цитированием
Старый 13.08.2019, 14:12   #3
meidiland
 
Регистрация: 28.10.2013
Сообщений: 3
По умолчанию

Цитата:
Сообщение от IgorGO Посмотреть сообщение
Код:
=СУММПРОИЗВ(R[1]C[-21]:R[2]C[-2]*(ОСТАТ(СТОЛБЕЦ(RC[-21]:RC[-2]);4)>0))
Спасибо большое за отклик, но не совсем понял Вашу идею. Я пытаюсь сделать, чтобы сумма была не в одной итоговой ячейке, а в разных.
Т.е. есть исходный массив (в моем примере строка №1).
А во второй строке я смог бы в разных ячейках протянуть формулу, так чтобы в A3 была сумма (A1:C1), в B3 сумма (E1:G1) и т.д.
Значения D1, H1 и т.д., т.е. каждое 4е значение в массиве пропускалось бы (не использовалось в суммировании).
Я сделал формулу, которая просто каждые 3 следующих столбца суммировала. Но не могу додуматься как сделать, чтобы ещё и пропускала 1 столбец. И вообще возможно ли это. Пока что решил проблему удалением из массива каждого 4го столбца полуручным способом и использованием моей формулы, но для опыта интересно было бы узнать, возможно ли это автоматизировать без макросов, только формулами..
meidiland вне форума   Ответить с цитированием
Старый 13.08.2019, 14:27   #4
сфинкс
Форумчанин
 
Аватар для сфинкс
 
Регистрация: 17.06.2012
Сообщений: 344
По умолчанию

группировка позволяет буквально тянуть
и сумма соответствует требующимся ячейкам
недостаток: смещение
Вложения
Тип файла: xlsx Book1308.xlsx (9.5 Кб, 13 просмотров)
учим C# зная basic & excel
сфинкс вне форума   Ответить с цитированием
Старый 13.08.2019, 14:49   #5
Elixi
Пользователь
 
Регистрация: 10.05.2019
Сообщений: 39
По умолчанию

meidiland, тoгда у вас фoрмула правильная, тoлькo надo устранить oдин "дoллар"

Код:
=СУММ(СМЕЩ(A$1;;(СТОЛБЕЦ()-1)*3;;3))
Elixi вне форума   Ответить с цитированием
Старый 13.08.2019, 15:04   #6
meidiland
 
Регистрация: 28.10.2013
Сообщений: 3
По умолчанию

Цитата:
Сообщение от Elixi Посмотреть сообщение
meidiland, тoгда у вас фoрмула правильная, тoлькo надo устранить oдин "дoллар"

Код:
=СУММ(СМЕЩ(A$1;;(СТОЛБЕЦ()-1)*3;;3))
О господи, как всё просто оказалось... Крутил вертел её, а про закрепление это и забыл. Спасибо огромное! И всем тоже спасибо за внимание!
meidiland вне форума   Ответить с цитированием
Ответ
Опции темы


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Вывести на экран значения произведений чисел a и b. Числа а изменяются от 1 до 11 с шагом 1, и - от 1 до 3 с шагом 0.2 ALEXandr20333 Паскаль, Turbo Pascal, PascalABC.NET 2 30.06.2014 09:48
Выполнить обработку массивов. предусмотреть описание массивов как динамических Vika_0_0 Паскаль, Turbo Pascal, PascalABC.NET 8 03.06.2012 10:12
Delphi, сравнение массивов, умножение массивов Marjasja Помощь студентам 0 22.05.2011 19:59
Суммирование массивов om3n Паскаль, Turbo Pascal, PascalABC.NET 5 16.09.2010 21:28
Суммирование ячеек с заданным шагом valerij Microsoft Office Excel 10 10.10.2007 00:22