Форум программистов
 
Регистрация на форуме тут, о проблемах пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail, а тут можно восстановить пароль

Вернуться   Форум программистов > Microsoft Office и VBA программирование > Microsoft Office Excel
Регистрация

Восстановить пароль
Повторная активизация e-mail

Купить рекламу на форуме 15-35 тыс рублей в месяц

Ответ
 
Опции темы Поиск в этой теме
Старый 30.11.2010, 18:27   #1
Avgur2000
Новичок
Джуниор
 
Регистрация: 30.11.2010
Сообщений: 2
По умолчанию Суммирование с увеличением шага

Есть задача: проссумировать в столбцах на Лист2 значения с Лист1 таким образом чтобы в каждой следующей строке на Лист2 была сумма следующих 12 столбцов с Лист1, т.е. например вот так :

1-я строка: СУММ(Лист1!A1:L1)
2-я строка: СУММ(Лист1!М1:Х1)
3-я строка: СУММ(Лист1!Y1:AJ1)
....и так далее.

Т.е. номера столбцов изменяются через 12.

Никто не подскажет как это можно сделать автоматически, или через формулу? Спасибо заранее!
Avgur2000 вне форума Ответить с цитированием
Старый 30.11.2010, 19:07   #2
IgorGO
МегаМодератор
СуперМодератор
 
Аватар для IgorGO
 
Регистрация: 05.02.2008
Сообщений: 9,452
По умолчанию

см.вложение
Вложения
Тип файла: rar Книга465.rar (3.2 Кб, 14 просмотров)
41001804815208 - ЮMoney бывш.Яндекс-кошелек благодарности за удачные советы и решения можно отправлять прямо сюда)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете
IgorGO вне форума Ответить с цитированием
Старый 01.12.2010, 11:41   #3
vikttur
Участник клуба
 
Регистрация: 16.05.2010
Сообщений: 1,249
По умолчанию

Ну и я покажу. Не люблю летучих, что поделать
Код:
=СУММ(ИНДЕКС(A$1:AJ$1;(СТРОКА(1:1)-1)*12+1):ИНДЕКС(A$1:AJ$1;(СТРОКА(1:1))*12))
vikttur вне форума Ответить с цитированием
Старый 01.12.2010, 11:48   #4
Avgur2000
Новичок
Джуниор
 
Регистрация: 30.11.2010
Сообщений: 2
По умолчанию

Спасибо огромное! С функцией СМЕЩ понятно, со вторым буду разбираться...)
Avgur2000 вне форума Ответить с цитированием
Старый 01.12.2010, 11:51   #5
vikttur
Участник клуба
 
Регистрация: 16.05.2010
Сообщений: 1,249
По умолчанию

Первая ИНДЕКС - начало диапазона, вторая - его конец.
vikttur вне форума Ответить с цитированием
Старый 01.12.2010, 13:16   #6
IgorGO
МегаМодератор
СуперМодератор
 
Аватар для IgorGO
 
Регистрация: 05.02.2008
Сообщений: 9,452
По умолчанию

=СУММ(СМЕЩ($A$1;;(СТРОКА(A1)-1)*12;;12))
=СУММ(ИНДЕКС(A$1:AJ$1;(СТРОКА(1:1)-1)*12+1):ИНДЕКС(A$1:AJ$1;(СТРОКА(1: 1))*12))
Виктор,
СТРОКА() в этой формуле - это правильная мысль. внес.
1.формула по-короче, видно на сколько (но это у меня тоже еще с тех времен, когда в формулу больше 256 символов нельзя было вписать, сейчас не так важно)
2.
Цитата:
...
3-я строка: СУММ(Лист1!Y1:AJ1)
....и так далее.
"....и так далее" не работает из-за короткого ИНДЕКСа(A$1:AJ$1...

термин "летучая" можно подробнее, а то я как-будто не местный... и, возможно, народу интересно
41001804815208 - ЮMoney бывш.Яндекс-кошелек благодарности за удачные советы и решения можно отправлять прямо сюда)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете
IgorGO вне форума Ответить с цитированием
Старый 01.12.2010, 14:05   #7
DV68
Форумчанин
 
Регистрация: 05.08.2009
Сообщений: 465
По умолчанию

Цитата:
Сообщение от IgorGO Посмотреть сообщение
...термин "летучая" можно подробнее, а то я как-будто не местный... и, возможно, народу интересно...
IgorGO,
в августе было:
http://www.programmersforum.ru/showthread.php?p=598582
"Все следует делать настолько простым, насколько это возможно, но не проще." Альберт Эйнштейн
DV68 вне форума Ответить с цитированием
Ответ
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Суммирование Mike02 Microsoft Office Excel 2 24.06.2010 18:49
Проблема с увеличением картинок Napste® JavaScript, Ajax 0 02.06.2010 17:53
Суммирование Slavik Microsoft Office Excel 4 08.04.2010 13:45
Цикл, время выполнения шага KiDoki Общие вопросы Delphi 9 19.12.2008 22:37