Форум программистов
 

Восстановите пароль или Зарегистрируйтесь на форуме, о проблемах и с заказом рекламы пишите сюда - alarforum@yandex.ru, проверяйте папку спам!

Вернуться   Форум программистов > Microsoft Office и VBA программирование > Microsoft Office Excel
Регистрация

Восстановить пароль
Повторная активизация e-mail

Купить рекламу на форуме - 42 тыс руб за месяц

Ответ
 
Опции темы Поиск в этой теме
Старый 07.12.2011, 15:49   #1
Acro
Пользователь
 
Регистрация: 21.10.2008
Сообщений: 39
По умолчанию Заминка с ИНДЕКС + ПОИСКПОЗ



Что то я всё подзабыл без практики. Нахожу наибольшее значение:

НАИБОЛЬШИЙ(A1:D6;1)

Хочу вернуть соответствующий параметр name из этой строки, но без прямого указания столбза в ПОИСКПОЗ не работает:

верно-
=ИНДЕКС(A1:D6;ПОИСКПОЗ(НАИБОЛЬШИЙ(A 1:D6;1);D1:D6;0);1)

неверно-
=ИНДЕКС(A1:D6;ПОИСКПОЗ(НАИБОЛЬШИЙ(A 1:D6;1);A1:D6;0);1)

ВПР и ГПР вроде не подходят

Через какие то встроенные функции можно получить это или лучше сразу макрос писать?
Вложения
Тип файла: zip test.zip (3.9 Кб, 11 просмотров)

Последний раз редактировалось Acro; 07.12.2011 в 15:55.
Acro вне форума Ответить с цитированием
Старый 07.12.2011, 16:04   #2
Казанский
Старожил
 
Аватар для Казанский
 
Регистрация: 31.12.2010
Сообщений: 2,133
По умолчанию

Код:
=ИНДЕКС(A1:D6;ПОИСКПОЗ(МАКС(A1:D6);ИНДЕКС(A1:D6;;ЧИСЛСТОЛБ(A1:D6));0);1)
exceleved@yandex.ru Яндекс.Деньги: 410011500007619
Казанский вне форума Ответить с цитированием
Старый 07.12.2011, 16:08   #3
vikttur
Участник клуба
 
Регистрация: 16.05.2010
Сообщений: 1,249
По умолчанию

Формула массива:
Код:
{=ИНДЕКС(A1:A6;МАКС(ЕСЛИ(B1:D6=МАКС(B1:D6);СТРОКА(1:6))))}
vikttur вне форума Ответить с цитированием
Старый 07.12.2011, 16:24   #4
Acro
Пользователь
 
Регистрация: 21.10.2008
Сообщений: 39
По умолчанию

Блин, спасибо
Примерно понимал в какую сторону крутить надо, но сам бы не дошёл до такого решения
Acro вне форума Ответить с цитированием
Ответ


Купить рекламу на форуме - 42 тыс руб за месяц

Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
ИНДЕКС + ПОИСКПОЗ - выдаёт #Н/Д и #ССЫЛКА! PARTOS Microsoft Office Excel 9 26.01.2017 14:26
Функция ИНДЕКС и ПОИСКПОЗ magana Microsoft Office Excel 9 01.04.2013 10:15
Формула ВПР, ПОИСКПОЗ Серёга0629 Microsoft Office Excel 9 18.07.2012 15:23
Задача на сопоставление данных. ВПР, ГПР, ИНДЕКС+ПОИСКПОЗ не помогают. Помогите! Alex_fch Microsoft Office Excel 7 29.11.2011 04:37
функция поискпоз Olya1985 Microsoft Office Excel 1 27.03.2011 12:25