Форум программистов
 
Контакты: о проблемах с регистрацией, почтой и по другим вопросам пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail.

Вернуться   Форум программистов > Microsoft Office и VBA > Microsoft Office Excel
Регистрация

Восстановить пароль
Повторная активизация e-mail


Донат для форума - использовать для поднятия настроения себе и модераторам

А ещё здесь можно купить рекламу за 25 тыс руб в месяц! ) пишите сюда - alarforum@yandex.ru

Ответ
 
Опции темы
Старый 13.06.2019, 11:33   #1
pornogluk
Новичок
 
Регистрация: 13.06.2019
Сообщений: 1
Репутация: 10
По умолчанию сформировать таблицу из прайса/ Условие - все номера от наименования по каталогу добавляются в одну ячейку, если цена одинаковая

Есть такая таблица с данными

Код:
Подшипник ступицы                                   503103E200	 	MOBIS	3 420,00	1,00
Подшипник ступицы	                          503103E100	 	MOBIS	3 420,00	1,00
Подшипник ступицы	                          503103E201	 	MOBIS	3 420,00	1,00
Подшипник ступицы	                          503103E102	 	MOBIS	3 420,00	1,00
Амортизатор передний левый	                     546514D101	 	MOBIS	5 225,00	1,00
Амортизатор передний левый (газ)                 54650FD150	    MOBIS	2 267,00	1,00
Подшипник ступицы	                          0K56B33047	 	MOBIS	3 061,00	2,00
Как на основе этой таблицы сформировать новую вида:
Код:
Подшипник ступицы                            503103E200	 	MOBIS	3 420,00	
	                                         503103E100	 	  
	                                         503103E201	 	 	 
	                                         503103E102
Подшипник ступицы	                 0K56B33047	 	MOBIS	3 061,00		
Амортизатор передний левый	          546514D101	 	MOBIS	5 225,00	
Амортизатор передний левый (газ)	  54650FD150	 	MOBIS	2 267,00
Условие - все номера от наименования по каталогу добавляются в одну ячейку, если цена одинаковая
Вложения
Тип файла: xls Прайс-лист Partex.xls (1.63 Мб, 13 просмотров)

Последний раз редактировалось pornogluk; 13.06.2019 в 11:42.
pornogluk вне форума   Ответить с цитированием
Старый 13.06.2019, 12:15   #2
Aleksandr H.
2 the Nation Glory
Профессионал
 
Аватар для Aleksandr H.
 
Регистрация: 27.05.2014
Адрес: Wild West Ukraine
Сообщений: 2,671
Репутация: 1096
По умолчанию

L9
Код:
=ЕСЛИ(C9=C8;"";C9)
M9
Код:
=D9
N9
Код:
=ЕСЛИ(И(C9=C8;F9=F8);"";F9)
O9
Код:
=ЕСЛИ(И(C9=C8;G9=G8);"";G9)
__________________
Mailto: media.project@ukr.net
Aleksandr H. вне форума   Ответить с цитированием
Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
При изменении наименования, автоматически вводится цена и пр. EmmaCarew Microsoft Office Excel 2 13.02.2017 17:12
Помогите написать программу: Составить таблицу стоимости порций сыра весом 50, 100, 150, …, 1000 г, если цена 1 кг сыра – 120 руб. василис Паскаль 4 28.01.2016 21:51
складывание значений в диаграмме если одинаковая дата pirat2k Базы данных (ADO.NET, LinqToSql, ORM Entity Framework, NHibernate) 3 17.04.2014 20:05
Данные не добавляются в таблицу Dozent БД в Delphi 2 20.02.2013 13:41
Проверить тридцать одну ячейку, если меньше нуля. segail Microsoft Office Excel 10 28.09.2010 21:13


11:18.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.