Форум программистов
 
О проблемах с регистрацией пишите сюда - alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail, а тут можно восстановить пароль.

Вернуться   Форум программистов > Microsoft Office и VBA программирование > Microsoft Office Excel
Регистрация

Восстановить пароль
Повторная активизация e-mail


Закрытая тема
Ваша тема закрыта, почему это могло произойти? Возможно,
Нет наработок или кода, если нужно готовое решение - создайте тему в разделе Фриланс и оплатите работу.
Название темы включает слова - "Помогите", "Нужна помощь", "Срочно", "Пожалуйста".
Название темы слишком короткое или не отражает сути вашего вопроса.
Тема исчерпала себя, помните, один вопрос - одна тема
Прочитайте правила и заново правильно создайте тему.
 
Опции темы
Старый 25.03.2008, 12:51   #1
Жираффа
Пользователь
 
Регистрация: 22.02.2008
Сообщений: 11
По умолчанию узнать, принадлежит ли значение массиву

как узнать , совпадает ли значение в ячейке А10 с одним из значений массива. (со значениями из столбца ячеек: С1, С2, С3, С4.....)

не используя при этом функцию "ИЛИ" !!!!!

сейчас это у меня реализовано с помощью такой формулы:

=ЕСЛИ(ИЛИ(А10=С1;А10=С2;А10=С3;А10= С4....................);"совпадает" ;ЛОЖЬ)
Жираффа вне форума
Старый 25.03.2008, 12:53   #2
Жираффа
Пользователь
 
Регистрация: 22.02.2008
Сообщений: 11
По умолчанию

смысл в том, что если столбец с большим количеством значений (С1, С2.....С11) , то очень громоздкая и неудобная формула получается.

думаю, что возможно это сделать намного проще! но вот как ?!
Жираффа вне форума
Старый 25.03.2008, 12:56   #3
ZORRO2005
Форумчанин
 
Аватар для ZORRO2005
 
Регистрация: 26.11.2006
Сообщений: 584
По умолчанию

{=ИЛИ(C1:C100=A10)}
=СЧЁТЕСЛИ(C1:C100;A10)>0
=ПОИСКПОЗ(A10;C1:C6;0)>0
=СУММПРОИЗВ(--(C1:C100=A1))>0

Последний раз редактировалось ZORRO2005; 25.03.2008 в 14:15.
ZORRO2005 вне форума
Старый 25.03.2008, 14:15   #4
Жираффа
Пользователь
 
Регистрация: 22.02.2008
Сообщений: 11
По умолчанию

не получилось

покажите на моём примере ??
Вложения
Тип файла: rar Лист Microsoft Excel.rar (1.9 Кб, 26 просмотров)
Жираффа вне форума
Старый 25.03.2008, 14:59   #5
Жираффа
Пользователь
 
Регистрация: 22.02.2008
Сообщений: 11
По умолчанию

вот я Жираф..
всё! получилось!

спасибо, ZORRO2005 !
Жираффа вне форума
Закрытая тема
Купить рекламу на форуме 20000 рублей в месяц

Опции темы


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Паскаль. Задачка по массиву -ZaK- Помощь студентам 6 17.10.2010 23:08
Поверхность по массиву точек на OpenGL в Delphi Mixasik Помощь студентам 1 21.07.2008 15:41
помогите доделать задачу по массиву braza Паскаль, Turbo Pascal, PascalABC.NET 7 06.05.2008 08:37
Принадлежит ли точка (x,y) круговому кольцу... Sota Паскаль, Turbo Pascal, PascalABC.NET 2 24.03.2008 17:03
Помогите с программой по массиву!!!Погораю!!! Radiofuck Паскаль, Turbo Pascal, PascalABC.NET 4 27.12.2006 20:57


Проекты отопления, пеллетные котлы, бойлеры, радиаторы
интернет магазин respective.ru
Пеллетный котёл Emtas
котлы EMTAS